Monday, 29 July 2024

Ookla Server Auto Start After Machine reboot or Network Outage..!

 Here i will show you how you can enable your Ookla server in Auto start mode when there is a machine reboot or any kind of network outage . find the configuration below.

 It is highly advisable to create own systemd services or udev rules to run scripts during boot instead of using this file  /etc/rc.d/rc.local .

make sure you have given executable permission to your own systems script. 

chmod +x /etc/systemd/system/speedtest.service


[root@localhost ~]# vi /etc/systemd/system/speedtest.service
[Unit]
After=network.target
[Service]
User=root
Group=root
WorkingDirectory=/usr/ookla/
Type=simple
KillMode=mixed
ExecStart=/usr/ookla/OoklaServer
TimeoutStartSec=30
TimeoutStopSec=60
Restart=always
[Install]
WantedBy=multi-user.target


[root@localhost ~]#



systemctl enable speedtest.service
 systemctl start speedtest.service
 systemctl status speedtest.service
systemctl daemon-reload



Saturday, 13 July 2024

How to Troubleshoot of a website if that website is not opening .

Let's say we will try on google.com. and we are not able to open the google.com website.

Step-1 = Ping to the website which is not opening.

First you have to check the ping to that website. There may be a possibility that ICMP is blocked in the destination end due to security concern...


C:\Users\hp>ping google.com
Pinging google.com [142.250.194.206] with 32 bytes of data:
Reply from 142.250.194.206: bytes=32 time=49ms TTL=58
Reply from 142.250.194.206: bytes=32 time=46ms TTL=58
Reply from 142.250.194.206: bytes=32 time=48ms TTL=58
Reply from 142.250.194.206: bytes=32 time=51ms TTL=58
Ping statistics for 142.250.194.206:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 46ms, Maximum = 51ms, Average = 48ms
C:\Users\hp>

You can see above that ICMP is not blocked in google end and we are getting Ping to google.com.Thats Fine..

Till Now we are getting the ping but 


2-Check Traceroute to google.com to verify whether you can reach the destination or not .


C:\Users\hp>tracert google.com

Tracing route to google.com [142.250.193.206]
over a maximum of 30 hops:

  1     1 ms     1 ms     1 ms  192.168.0.1
  2     2 ms     1 ms     1 ms  103.14.9.18
  3    43 ms    44 ms    42 ms  103.15.9.17
  4    43 ms    43 ms    44 ms  103.6.9.26
  5    46 ms    45 ms    46 ms  72.4.203.200
  6    45 ms    46 ms    45 ms  142.250.244.151
  7    45 ms    45 ms    45 ms  142.250.54.97
  8    47 ms    44 ms    46 ms  del11s17-in-f14.1e100.net [142.250.193.206]

Trace complete.

C:\Users\hp>


As you can see above that the Traceroute is showing OK and we are able to reach the destination.


Step-3=Check the DNS resolve , weather the DNS is proper or not .

C:\Users\hp>nslookup
Default Server:  UnKnown
Address:  192.168.0.1
> google.com
Server:  UnKnown
Address:  192.168.0.1
Non-authoritative answer:
Name:    google.com
Addresses:  2404:6800:4002:81c::200e
          142.250.194.206
>


As you can see above that DNS is working properly and we are able to resolve from name to IP and IP to name.


Step-4= Check the Telnet to Website whether the https://google.com is open on 443 port or not.

To check in Telenet , Got to your cmd and write the telnet google.com 443

C:\Users\hp>telnet google.com 443




You can see above that we are able to access the website on 443 port , it means everything is fine .


Summary.





Till now everything is fine from our end but still we are not able to access the website . So now you have to contact your ISP for checking this issue because this issue can be with your public IP or in ISP end there is some routing issue such as Assymetric routing or Routing failure in the transit etc etc..and also there is a possibility that somewhere in transit  Your public IP address is blocked.


How To Hide Pinned Bookmarks on Browser(Google Chrome)

 Let's say you have given your computer screens on remote to someone to troubleshoot something in your computer. in that case, let's say you don't want to show your pinned bookmark of your browser to that person.


To hide the bookmark, You have to press the (Ctrl+Shift+B) key to hide the pinned bookmarks of your browser..!

Wednesday, 10 July 2024

2 ISP Auto Failover--(2 Broadband internet failover Configuration)

 Here i will show you the simple configuration of Aoto switchover between two isp .



Note to remember.


In this configuration, At a time one link will be worked .So if the primary link will be completely down the link will be switched over to secondary.


In this configuration simultaneously you can't send the traffic on 2 isp.


Step-1:Create the interface group.

/interface list
add name=WAN
add name=LAN
/interface list member
add interface=eth1 list=WAN
add interface=eth2 list=WAN
add interface=eth3 list=LAN


Step-2-Configure The IP address.

/ip address
add address=172.20.20.1/30 comment=VODA interface=eth1 network=172.20.20.0
add address=172.20.20.5/30 comment=AIRTEL interface=eth2 network=172.20.20.4
add address=172.21.21.1/24 comment=MY_LAN interface=eth3 network=172.21.21.0

Step-3-Configure the IP route.


/ip route
add check-gateway=ping distance=1 gateway=172.20.20.2 
add check-gateway=ping distance=2 gateway=172.20.20.6



Step-4-Configure the NAT for both the interface.

/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN