Tuesday, 30 April 2024

All You Need to Know About Prefix Lists..!

 The prefix list have been introduced speclfically for route / prefix filtering they allow to match a range of prefixes within an address block this is not easy to implement with an IP extended ACL and not all routing protocols support this use of IP extended ACL.


Example:

ip prefix-list EXAMPLE permit 10.100.0.0/16 ge 20 le 24

This means all prefixes within 10.100.0.0/16 with prefix length between 20 and 24 are accepted:

10.100.128.0/17 is not a match
10.100.20.0/24 is a match
10.100.21.128/25 is not a match
10.100.0.0/23 is a match

The most notable and important difference is that a prefix list allows you to filter networks based on their subnet mask. ACLs used in distribute list filter networks only by network addresses but they do not perform matching on subnet mask; in other words, for an ACL used in distribute list, the networks 192.168.10.0/24 and 192.168.10.0/28 are indistinguishable. Moreover, the prefix list also allows you to specify networks in a much more natural format than ACLs.


Example -1: How To Permit all the prefix.

ip prefix-list ALL-Networks permit 0.0.0.0/0 le 32


Example #2: How to block the prefix 11.0.0.0/24.


ip prefix-list DENY-11 deny 11.0.0.0/24

Due to the implicit deny of the prefix list, a second line is required to permit the other networks:

ip prefix-list DENY-11 permit 0.0.0.0/0 le 32

Note: the first line can be written like:

ip prefix-list DENY-11 deny 11.0.0.0/24 ge 24 le 24


Example #3: Permit only the default route

ip prefix-list DEFAULTE-ROUTE permit 0.0.0.0/0


Example #4: Permit all prefixes in the 11.0.0.0/16 with subnet mask less or equal /30

ip prefix-list TEST permit 11.0.0.0/16 le 30

this check the first 16 bits of the prefix 11.0.0.0, where the subnet mask must be less than or equal to 30.

So, if you have these networks:


11.0.0.0/24
11.11.11.0/24
11.0.11.128/30
11.0.0.10/32

Only the first and the third are valid. The second is not valid due to different prefix, while the fourth due to a greater subnet mask.


Example #5: Permits all prefixes in the 192.168.0.0/24 with subnet mask between 26 and 30 bits.


ip prefix-list TEST permit 192.168.0.0/24 ge 26 le 30


So, if you have these networks:

192.168.123.0/24
192.168.0.0/30
192.168.0.0/16
192.168.0.0/8


Only the second statement is valid; the third and fourth are not valid due to lesser subnet mask and the first one is not valid due the different network.


Example #6: Deny all the loopback network (/32)

ip prefix-list Test deny 0.0.0.0/0 ge 32 le 32


ip prefix-list Test permit 0.0.0.0/0 le 32


The first line block all the network with subnet mask /32, while the last line permit any.


How to stop advertising default route towards downstream BGP peer.#Prefixlist#Huawei

How to stop advertising the Default route towards your downstream BGP peer. Here is my diagram given below.



ISP Router Configuration Given Below.


Step-1 := Configure the Prefix-List.

#
ip ip-prefix BGP-NO-DEFAULT-ROUTE index 10 deny 0.0.0.0 0
ip ip-prefix BGP-NO-DEFAULT-ROUTE index 20 permit 0.0.0.0 0 less-equal 32
#

Step-2 := Configure the route-policy.


#
route-policy BGP-NO-DEFAULT-ROUTE permit node 10
 if-match ip-prefix BGP-NO-DEFAULT-ROUTE

Step-3 :=Apply On the peer .

#
  peer 10.1.22.34 route-policy BGP-NO-DEFAULT-ROUTE export
#
#


Monday, 29 April 2024

How To create the sub-interface on Huawei6720 ..!

 To create the sub-interface in the Huawei 6720 model, Make sure you have disabled the switch port command on the port. Because a subinterface can be created on the L3 port so you have to disable the switch port by using the command "port switch"

use the below command to disable the switch port.


#

interface XGigabitEthernet0/0/4

 undo portswitch

#



Now let's verify it .



<Jumtara>display interface XGigabitEthernet 0/0/4
XGigabitEthernet0/0/4 current state : DOWN
Line protocol current state : DOWN
Description:
Route Port,The Maximum Frame Length is 9216
Internet protocol processing : disabled
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 00c4-06c0-7395
Last physical up time   : 2024-04-29 12:26:49
Last physical down time : 2024-04-29 12:44:00
Current system time: 2024-04-29 13:18:08
Port Mode: COMMON FIBER, Transceiver: 1000_BASE_LX_SFP
Speed : 1000,   Loopback: NONE
Duplex: FULL,   Negotiation: ENABLE
Mdi   : -,      Flow-control: DISABLE


Now let's create the subinterface.


[Jumtara]interface XGigabitEthernet 0/0/4.393

[Jumtara-XGigabitEthernet0/0/4.393]





Tuesday, 23 April 2024

Subnet Mask & Wildcard Mask Explanation in a Simple Way..!!

 Subnet Mask tells us the number of network bits and the number of host bit present in an IP.

Wildcard mask is used to identify which bits in an IPv4 address to match. In which binary 1 is equal to a match and binary 0 is not a match. 

A Wildcard mask is used in ACL to match the IP address in a better way to permit or deny . and also in some routing protocols, we use wildcard masks to advertise the network such as OSPF etc..!

Wildcard masks use the following rules to match binary 1s and 0s:

  • Wildcard mask bit 0: Match the corresponding bit value in the address.

  • Wildcard mask bit 1: Ignore the corresponding bit value in the address.


How to calculate the Wildcard mask.??.

Wildcard Mask = 255.255.255.255 - Actual Subnet Mask.

Example-1.


Network=192.168.3.0/24
Subnet Mask=255.255.255.0

Starting value                     

255.255.255.255

Subtract the subnet mask

–255.255.255. 0

Resulting wildcard mask

0. 0. 0.255



Example 2

Network=192.168.1.0/28
Subnet Mask=255.255.255.240



Starting value

255.255.255.255

Subtract the subnet mask

–255.255.255.240

Resulting wildcard mask

0. 0. 0. 15



Example 3

Network=192.168.1.0/23
Subnet Mask=255.255.254.0


Starting value

255.255.255.255

Subtract the subnet mask

–255.255.254. 0

Resulting wildcard mask

0. 0. 1.255




IPv4 Subnetmask and Wildcardmask Cheetsheet..!

List of wildcard masks
SlashNetmaskWildcard mask
/32255.255.255.2550.0.0.0
/31255.255.255.2540.0.0.1
/30255.255.255.2520.0.0.3
/29255.255.255.2480.0.0.7
/28255.255.255.2400.0.0.15
/27255.255.255.2240.0.0.31
/26255.255.255.1920.0.0.63
/25255.255.255.1280.0.0.127
/24255.255.255.00.0.0.255
/23255.255.254.00.0.1.255
/22255.255.252.00.0.3.255
/21255.255.248.00.0.7.255
/20255.255.240.00.0.15.255
/19255.255.224.00.0.31.255
/18255.255.192.00.0.63.255
/17255.255.128.00.0.127.255
/16255.255.0.00.0.255.255
/15255.254.0.00.1.255.255
/14255.252.0.00.3.255.255
/13255.248.0.00.7.255.255
/12255.240.0.00.15.255.255
/11255.224.0.00.31.255.255
/10255.192.0.00.63.255.255
/9255.128.0.00.127.255.255
/8255.0.0.00.255.255.255
/7254.0.0.01.255.255.255
/6252.0.0.03.255.255.255
/5248.0.0.07.255.255.255
/4240.0.0.015.255.255.255
/3224.0.0.031.255.255.255
/2192.0.0.063.255.255.255
/1128.0.0.0127.255.255.255
/00.0.0.0255.255.255.255






Port Forwarding Configuration in Cisco 800(C881-K9) Router...!!

 Hey guys...

In this lesson, i will give you a quick overview of port forwarding in cisco 800 VPN router.

The task is here that , in my diagram , I have e a web server in MY LAN with having a private IP address that is 192.168.1.10. and I want to access that web server from outside my network but as I have private IP on the web server I will not be able to access that without port forwarding .

i have one public IP which is assigned on my WAN interface that is connected to ISP . So I need to map my wan interface public IP to my Web server Private IP.


Find the configuration given below.

Syntax.

Use this command to enable port forwarding:

ip nat inside source static tcp "inside local ip" "external ip" 20 extendable
ip nat inside source static tcp "inside local ip" "external ip" 21 extendable
ip nat inside source static tcp "inside local ip" "external ip" 1020 extendable

An example of a FTP server POrt forwarding given below

router (conf)# ip nat inside source static tcp 192.168.1.20 85.84.84.45 21 extendable


My Web server Port forwarding Example..!


## You can use the same port for inside and outside users.

Router(config)# ip nat inside source static tcp 192.168.1.10 80 10x.xx.x.13 80 extendable

OR

## You Can use the different port for inside and outside users.(Recommended)

Router(config)#ip nat inside source static tcp 192.168.1.10 80 10x.xx.x.13 81 extendable


 

Cisco 800(C881-K9)WAN Through PPPoE & LAN Site Access Configuration ...!!

 Cisco 800 is an IOS-based router that is very popular in small enterprises. Let's look at the configurations and how you can configure it in your organization. 

Basically, I will show you, How you can distribute the internet in your LAN through this router(Cisco 800(C881-K9)).

In my network , I will use PPPoE connection with my ISP to build my WAN(Internet) connection.Find my Diagram Given below .



Step-1:- First You have to create the Dialer in the router for PPPoE.

interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp pap sent-username ipnoc_isp password 0 12345

Step-2 Once the dialer is created then you have to assign that dialer under the WAN interface. The interface will be connected to the ISP modem.


interface FastEthernet4
 description CONNECTED-TO-ISP
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1



Step-3-LAN Side Configuration.


In LAN side we will create the vLAN 10 and our LAN port would be the access port of vlan 10 .

##Configure The VLAN..

!
vlan 10
!

##Configure The VLAN Interface and give the IP address ..

interface Vlan10
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in

##Configure the Fa2 As access port which will be connected to our LAN segment...!

interface FastEthernet2
 switchport access vlan 100
 switchport mode access
 no ip address
!

Step-4- NAT configuration for Internet User.

First, you create the ACL which will match your LAN IP pool and then configure a NAT.

access-list 10 permit 192.168.1.0 0.0.0.255

#

ip nat inside source list 10 interface Dialer1 overload

Once the NAT will be configured then apply on the interface.

##WAN Interface##

interface Dialer1
 ip nat outside


##LAN Interface###

interface Vlan10
 ip address 192.168.1.0 255.255.255.0
 ip nat inside


Step-5:-( Optional).

#
ip route 0.0.0.0 0.0.0.0 10.10.10.1 name ISP_gateway

#
dialer-list 1 protocol ip permit 
#

The above 2 commands are optional , because in PPPoE , The default route is injected automatically ..!



Monday, 22 April 2024

What Happens when a router receives a packet..!!..Routing Process of a router..!

 What happens, when a router receives the packet?



Upon receiving the Packet, a router has to follow three  step process before it routes the packets:

-> Routing

-> Forwarding (Switching)

-> Encapsulation

Let’s discuss each one of them in detail

Routing Process: Routing process is nothing but routers control plane. Router records a routing table listing what route should be used to forward a data packet, and through which physical interface connection. Router learns your network routes information either by static configuration or by using dynamically configure routing protocol like IGP (OSPF, EIGRP, RIP, IS-IS) or though Exterior routing protocol like BGP.

When router receives any packet it has to remove Layer 2 header information present on packet(Example:In Ethernet, source and destination Mac address present on L2 header). Once router remove L2 information it looks for Layer 3 information available on packet that is source and destination IP address.

For moving L3 packet between interfaces, router checks destination address and finds longest-prefix match in IP routing table to find outgoing interface. In IPv4 router uses longest mask to identify best routing entry for forwarding packet.

Example: Let’s assume we have configured 3 different static routes with different subnet mask.

Sh ip route 1.1.1.1

ip route 1.1.1.0 255.255.255.0 fa0/2

ip route 1.1.0.0 255.255.0.0 fa0/1

ip route 1.0.0.0 255.0.0.0 fa0/0

In above example when router does route lookup for destination address 1.1.1.1 out of 3 entries router will choose longest-prefix length match entry i.e. 1.1.1.0/24 , because destination address has most common bits matches with selected route and will forward packet out fa0/2.

Destination prefix

Binary Splitting

1.1.1.1

00000001 00000001 00000001 00000001

1St Entry 1.1.1.0/24

00000001 00000001 00000001 00000000

2nd Entry 1.1.0.0/16

00000001 00000001 00000000 00000000

3rd Entry 1.0.0.0/8

00000001 00000000 00000000 00000000

Now for any other destination prefix like 1.1.2.0 longest match is 1.1.0.0/16 and for 1.2.0.0 it would be 1.0.0.0/8

Longest match possible in IPv4 routing is /32 (255.255.255.255) and shortest match possible is default route i.e. 0.0.0.0

->If there are multiple routes with same subnet mask learned via same protocol by router then router chooses lowest metric between them.



For Example: Eigrp use composite “metric” and Ospf uses “Cost” for comparison.

->If there is multiple routes with same subnet mask learn via different protocol on router then router chooses lowest administrative distance (AD).

->Last and important point is recursive lookup: which states that whenever there is route lookup more than once it will be termed as recursive lookup. It has to be done by router till destination address point towards any physical or logical interface.

Example:

We have a network 1.1.1.1 connected somewhere and we are reaching it by interface fa0/0 having next-hop IP address 2.2.2.2.So we can configure static route in two different ways either we can define next-hop IP address i.e.2.2.2.2 or we can mention interface number fa0/0 as gateway shown below.

ip route 1.1.1.1 255.255.255.255 2.2.2.2

ip route 1.1.1.1 255.255.255.255 FastEthernet0/0

Both statements look same although both have different meaning.When you point destination address to next hop as exit interface you don’t need further route lookup as router assume destination address is directly connected to that interface. But when you point destination address to any next hop ip address, we need another route lookup also for next hop ip address is referring as recursive lookup.

To get more information on how static route work when you set gateway as Next-Hop IP address or to Next-Hop interface please refer this document.

Forwarding process: It is also known as switching process. Once router finds outgoing interface, packet move between interfaces by switching process. This is done by process switching, fast switching or cef switching. Forwarding can be done by using adjacency tables reside on the route processor or on interface cards that support switching.

-> Process switching requires the device CPU to be involved for every forwarding decision.

-> Fast switching still uses the CPU for initially packets and to fill cache table in router. Once initial packet has been forwarded, the information about how to reach the destination is stored in a fast-switching cache’s .when another packet going to the same destination, the next hop information can be re-used from the cache and so the router processor doesn’t have to look into it, but if the information is not cached the CPU will have to process entire packets.

-> When CEF mode is enabled it build the CEF FIB and adjacency tables reside on the route processor, and the route processor performs the express forwarding.

In switching process device do actual packet link load balancing depending on the methodology we use.

Encapsulation process: L3 header will remain intact unchanged except for nating, vpn etc. layer 2 headers keep changing on hop by hop basis, depending on transmission media. For transmitting L3 packet on wire router need to find out l2 information for packets and it’s depending on the type of media we are using for transmission.

To explain encapsulation process in bit detail, I have created a small topology shown as below in diagram.



As discussed above, depending on the transmission media (In this example transmission media is Ethernet) MAC address in layer 2 headers will keep changing on hop by hop basis.

To generate some traffic, Lets ping from R3 to R2 interface address.As soon as R1 receives the packet from R3, It will remove the L2 information sent by R3 and check the L3 information that is source (20.1.1.2) and destination address (10.1.1.1) available on packet. Then it will look into its routing table to find out going interface i.e. fa0/0 in above example. Once router identify outgoing interface it will attach L2 header before putting the packet on the wire. So now R1 will attach its own interface Mac address as source and R2’s as destination mac address.

Address resolution protocol (ARP) table on R1:



To get closer packet level overview, I have also attached some packet capture taken on R1's interfaces.

Packet capture on R1’s Fa0/1:



Packet capture on R1’s Fa0/0:



Multipoint Broadcast Interfaces, Routing, and ARP

 

When the router needs to route a packet which matches an entry in the routing table with a next-hop value, it performs Layer 3 to Layer 2 resolution for the next-hop address. If it matches an entry in the routing table with just the outgoing/exit local interface, without a next-hop value, it performs Layer 3 to Layer 2 resolution for the final destination of the IP packet.

From a design perspective, the ideal solution for this problem is to never configure a static route to point out a multipoint interface. Static routes should either point to the next-hop value of the neighbor on the multipoint interface or point to an interface only if it is point-to-point, such as a GRE tunnel, PPP or HDLC link.

 

When you configure a static route to use an interface attached to a broadcast media (e.g. ethernet), a Cisco router expects that the network is directly attached. As a result it has to ARP for anything that falls within the scope of your static route. Consider the following topology:



Chesterton# ip route 1.2.3.4 255.255.255.255 eth0/0

 

In this configuration, router Chesterton has to make an ARP request for 1.2.3.4/32 and broadcast it via Ethernet0/0. He is now totally reliant on one of two possiblities:

1.    A Static ARP entry

2.    Vegas will “proxy-arp” his request

 

 

If neither of these conditions exists, he won’t be able to reach his destination. The topology presented is a minor case, and as a result there’s no real problem with it. If we were to increase the load, we begin to see a greater set of problems.



Chesterton# no ip route 1.2.3.4 255.255.255.255 eth0/0

Chesterton# ip route 0.0.0.0 0.0.0.0 eth0/0

 

Now that we’ve added a little more scope for router “Chesterton” to look for, we have a higher possibility for impact. If he attempts to reach 8.8.8.8, 180.0.123.12, and 5.4.3.2 we will see arp entries for each address (all of which will have the MAC address of router Vegas’ e0/0 interface). If there is a lot of traffic from Chesterton to the internet, we have the potential to fill up the arp-cache; thus, causing memory problems that will lead to forwarding problems.

Bottom Line (TL;DR version):


Yes, you can do it and it shouldn’t be a big deal on a small deployment; However, it’s bad practice and could really backfire in a big network.

 

 

When configuring a static route, the following options are available:

 

1-specify only the next-hop value; route is valid as long as a route exists for the next-hop value.

2-Specify only the local outgoing interface; route is valid as long as the interface is in the UP/UP state.
3-Specify both next-hop value and local outgoing interface.

 

When the third option is selected, the local outgoing interface behaves like a condition for the next-hop value and should be read like: this static route is valid only if the configured next-hop value is reachable over the configured interface, which means as long as the interface is in the UP/UP state and has nothing to do with IP/ARP/NHRP functionality with the next-hop.

Thursday, 18 April 2024

GPON SFP Types..!

 The main difference is the output optical power which we called as TX Power of module . Class C++ GPON SFP module output optical power is about 7dBm, the Class C+ GPON SFP module output optical power is about 5dBm. Of course, their optical receiver sensitivity is also different. The Class C++ optical receiver sensitivity is best.

The detailed specification parameter table comparison is as below:

GPON SFP modules

Type

Class B+ GPON SFP module

Class C+ GPON SFP module

Class C++ GPON SFP module

wavelength 

Tx1490nm

Tx1490nm

Tx1490nm

Rx1310nm

Rx1310nm

Rx1310nm

rate 

Tx2.488Gbit/s

Tx2.488Gbit/s

Tx2.488Gbit/s

Rx1.244Gbit/s

Rx1.244Gbit/s

Rx1.244Gbit/s

Mini Output Power

1.5dBm

3dBm

6dBm

Mini Output Power

5dBm

7dBm

10dBm

Optical Receiver Sensitivity

-28dBm

-32dBm

-35dBm

Optical Connector

SC

SC

SC

Fiber type

Single mode

Single mode

Single mode

Receiver Overload

-8dBm

-8 dBm

-15dBm

Extinction Ratio

10dB

10dB

8.2dB