Vlan-based QoS can be used to apply QoS (and hence prioritize) traffic on interfaces belonging to a particular vlan. The interface on which you intend to apply QoS should be configured with 'mls qos vlan-based' and the actual QoS service policy should be configured under the vlan interface.
Step-1=(Classification of traffic on which QoS needs to be applied)
Distribution1(config)#ip access-list extended voice-traffic
Distribution1(config-std-nacl)#permit ip 192.168.100.0 0.0.0.255 any (suppose this is your vlan 10 subnet)
Distribution1(config-ext-nacl)#exit
Distribution1(config)#class-map Class-A
Distribution1(config-cmap)#match access-group name voice-traffic
Distribution1(config-cmap)#exit
Step-2= (Marking the classified traffic)
Distribution1(config)#policy-map sample-policy1
Distribution1(config-pmap)#class Class-A
Distribution1(config-pmap-c)#set dscp af21 (you can include all the QoS config here)
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit
Distribution1(config-pmap)#class Class-A
Distribution1(config-pmap-c)#set dscp af21 (you can include all the QoS config here)
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit
Step-3= (Apply QoS to the interface)
(config) interface gigabitethernet 1/2
(config-if)#switchport access vlan 10
(config-if)#mls qos vlan-based <<---- You apply vlan-based QoS on the physical interface
(config-if)#exit
(config-if)#switchport access vlan 10
(config-if)#mls qos vlan-based <<---- You apply vlan-based QoS on the physical interface
(config-if)#exit
(config-if)#interface vlan 10
(config-if)#service-policy input sample-policy1 (This Service policy will now be applied to gi1/2)
(config-if)#service-policy input sample-policy1 (This Service policy will now be applied to gi1/2)
For all the interfaces on which you intend to apply QoS, mls qos vlan-based needs to be configured and the service policy just needs to be configured under the interface vlan.
Instead of using vlan based qos, you can also apply the service policy directly under the physical interfaces.
No comments:
Post a Comment